When building a Lutece core or plugin, I get a BUILD FAILURE with the following message : Failure executing javac, but could not parse the error: javac: invalid target release: 1.5

You need Java 5 to build Lutece. Make sure that Maven is invoked with a Java 5 VM : your JAVA_HOME environment variable should be set to the base directory of your Java 5 JRE or SDK installation.


POM configuration

When building a Lutece project, I get a BUILD ERROR with the following message : Cannot find lifecycle mapping for packaging: 'lutece-XXX'.

Check that you have declared maven-lutece-plugin in your project's POM (the pom.xml file in the root directory). For an example of how to do this, see the usage page.